Lame Neopixel

Page 1 sur 4 1, 2, 3, 4  Suivant

Aller en bas

Lame Neopixel

Message  Djecko le Mar 12 Déc - 10:23

Bonjour à tous zé à toutes,

Je lance ce sujet dans l'espoir d'y centraliser des informations pour celles et ceux qui souhaiteraient comme moi se lancer dans la fabrication d'une lame Neopixel, donc si vous avez des connaissances sur le sujet, c'est l'endroit idéal pour les partager ! Astuces de montage, références de composants, bonnes adresses où les trouver, etc.

Pour l'instant, j'attends de recevoir toutes les pièces :
- deux led strip WS2812 de 144 led avec PCB blanc (reçus),
- lame polycarbonate fine 1 pouce avec son embout rond (TCSS),
- mousse pour lame fine 1 pouce (TCSS),
- connecteur TCSS,

Le tout sera monté sur un sabre K4 équipé d'une Nano ou d'une Prizm (commandé chez JQ, actuellement en attente), j'attends de les recevoir pour commencer l'assemblage.

Une fois le projet plus avancé, je compte partager aussi les réglages des cartes son pour exploiter au mieux la lame.

Pour la réalisation de la lame, j'ai trouvé une excellente vidéo tuto de Khal de KR Sabers, il y détaille toute la procédure de façon claire :
https://www.youtube.com/watch?v=va1R3Wn1PcQ

Au passage, sur son site (découvert trop tard), on peut y commander toutes les pièces : https://thesaberarmory.com/product-category/components/neopixelsled-strips/

Voilà ce que j'ai pour l'instant, si vous avez d'autres infos ou des conseils à partager, ils seront les bienvenus !

D'avance merci pour le partage Wink

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Sam 16 Déc - 21:06

Salut !

J'ai fait le même projet. J'ai suivi pas à pas la vidéo que tu cites et cela fonctionne parfaitement ! J'ai utilisé deux bandes de LED type WS2812 mais j'ai vu plus tard qu'on pouvait en utiliser 3 (dos à dos, en triangle).
Le câblage ne pose aucun problème particuliers.
Pour le connecteur, j'ai utilisé un connecteur 3 broches. Je ne comprends pas l'intérêt d'en avoir 4, mais je ne suis pas un pro de l'élec'.
Le tout est piloté par une NB avec les réglages standards de la notice.

Et à l'effet d'allumage progressif est juste..... incroyable ! J'ai eu des frissons la première fois ! Après, je trouve presque que c'est trop lent (par rapport au son) et je ne sais pas comment régler cela.

Pour les fournitures et petites pièces électroniques, je passe volontiers par https://fr.aliexpress.com/ les prix défient toute concurrence (tu achètes directement aux chinois sans intermédiaire) mais il faut compter 2 à 3 semaines de livraison.

J'ai hâte de voir la suite de tes travaux !

Smile
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Dim 17 Déc - 15:21

Merci Beloube pour ton retour !

Mon futur sabre étant toujours en rupture de stock chez JQ, je commence doucement la réalisation de la lame pour pouvoir faire des tests sur platine.

Première surprise, j'ai payé un œil mes led strip chez Adafruit pour me rendre compte que je n'avais pas pris le bon modèle... Bref, erreur de débutant ! J'ai des bandeaux RGB et non pas RGBW, ça devrait quand même le faire.

Par contre, les connecteurs sont collés car c'est le modèle gainé (voir la photo). Heureusement, ça se démonte assez facilement mais je fais très attention à ne pas faire de dommages collatéraux.

A suivre !


Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Kruhl Ilios le Dim 17 Déc - 16:57

Et en quoi RGB n'est pas bon?
avatar
Kruhl Ilios

Messages : 274
Date d'inscription : 27/10/2014
Age : 36
Localisation : Val de Marne 94 Limeil Brevannes

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Dim 17 Déc - 18:59

Je confirme : ça passe nickel !
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Dim 17 Déc - 20:19

En soit cela dépend de la couleur des clashs que tu souhaites avoir sur ton sabre.

Je voulais des clashs en blanc cela aurait été plus facile avec une RGBW même si j'ai cru comprendre que le blanc était la couleur qui tirait le plus de courant.

Bref, je verrai bien une fois monté pour ajuster la couleur des clashs.

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Kruhl Ilios le Dim 17 Déc - 20:27

Djecko a écrit:En soit cela dépend de la couleur des clashs que tu souhaites avoir sur ton sabre.

Je voulais des clashs en blanc cela aurait été plus facile avec une RGBW même si j'ai cru comprendre que le blanc était la couleur qui tirait le plus de courant.

Bref, je verrai bien une fois monté pour ajuster la couleur des clashs.

Evite le blanc, avec ce type de lame tu videras la batterie grand V
avatar
Kruhl Ilios

Messages : 274
Date d'inscription : 27/10/2014
Age : 36
Localisation : Val de Marne 94 Limeil Brevannes

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Dim 17 Déc - 20:39

Merci Kruhl, ça confirme bien ce que j'avais cru comprendre.

Comme la lame sera bleue, j'opterai certainement pour des clashs oranges, j'affinerai par la suite !

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Kruhl Ilios le Dim 17 Déc - 20:51

Le plus galère avec les lames Neopixel sont le placement et la fixation des plugs je trouve. Sinon c'est clair que c'est top
avatar
Kruhl Ilios

Messages : 274
Date d'inscription : 27/10/2014
Age : 36
Localisation : Val de Marne 94 Limeil Brevannes

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Dim 17 Déc - 22:37

Kruhl Ilios a écrit:
Evite le blanc, avec ce type de lame tu videras la batterie grand V

Haaaaaaa....... c'est pour ça !!!

Après, j'ai pas compris ce que tu appelles "placement et fixation des plugs"... Pour ma part, j'ai fait exactement comme dans la super vidéo de KR Saber. J'ai trouvé un vieux bouton de potentiomètre qui avait le diamètre interne de la lame et hop ! Ca marche super bien Smile
En plus, quand la lame est démontée, la prise à l'intérieur du manche fait un bel effet !
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Thalree Kordo le Lun 18 Déc - 14:39

Kruhl Ilios a écrit:
Evite le blanc, avec ce type de lame tu videras la batterie grand V

Pas plus qu'avec les autres couleurs, si tu veux du blanc pour le FoC sans vider ta batterie trop rapidement tu mets 3 fois la valeur 341 dans le paramètre "fdrive".

Wink Wink
avatar
Thalree Kordo

Messages : 376
Date d'inscription : 04/01/2016
Age : 48
Localisation : Ile de France

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Mar 19 Déc - 16:57

Premier galop d'essai avec un câblage de fortune sur une breadboard.



J'ai suivi la doc et placé une résistance de 470 ohm sur la L3 où j'ai connecté le data du led strip.

Les deux bornes moins étant reliées aux sorties L1 et L2. D'ailleurs, je trouve étrange d'avoir 2 bornes moins sachant que je n'ai fait ce test qu'avec un seul led strip.

J'ai modifié la configuration de la carte de la sorte :

- override : ledstrip = 0 passé à 144 (nombre total de led de mon bandeau)
- dans les fichiers config des banques de son, j'ai mis : lsfadeon = 1 lsfadeoff = 1
- config bank1 : drive = 0, 0, 1023 (couleur principale bleue) et fdrive = 1023, 660, 0 (couleur FoC ambre)
- config bank2 : drive = 0, 1023, 0 (couleur principale verte) et fdrive = 341, 341, 341 (couleur FoC blanc)
- config bank3 : drive = 1023, 0, 0 (couleur principale bleue) et fdrive = 1023, 255, 0 (couleur FoC orange)
- focmix = 111 pour les trois banques

Si les trois couleurs apparaissent bien et l'effet de sortie et de rétractation est bien là, ça se complique par la suite.

En effet, la couleur verte ne pose aucun souci, les clashs sortent bien, rien à signaler ici.

Sur la couleur rouge, ça grésille sa mémé ! Et lorsque je tape sur la table pour les clashs : reboot carte. La même pour la couleur bleue, les grésillements en moins... ??? ...

J'ai fait une mesure rapide du courant, j'ai environ 1A pour le vert et le bleu et 1,2A pour le rouge. La batterie utilisée est une Panasonic NCR18650B, donc à priori c'est du bon (du moins c'est ce que j'ai cru comprendre) et on est bien en deçà de ce qu'elle peut délivrer.

Le grésillement sur le rouge m'inquiète et de voir que ça ne fonctionne pas super bien avec un seul bandeau, j'ai peur d'imaginer ce que ça donnerait avec les deux bandeaux en parallèle.

Quelqu'un saurait me dire où je me suis trompé ou bien quelle est l'erreur que j'ai commise ?

D'avance merci pour votre aide.

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Mar 19 Déc - 17:42

Deuxième test rapide en mettant le focmix à 001 (valeur par défaut) et 011, même constat...

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Mar 19 Déc - 18:41

Hello,
J'ai eu ce problème avec mes 3 "vieilles" piles R03 : elles n'avaient pas assez de pêche pour supporter les FoC et je reboutais systématiquement. Curieusement, c'est pour le bleu que ça passait le mieux mais le vert grésillait de ouf et le rouge ne s'allumait même pas jusqu'au bout du sabre !
J'ai fait un test avec une vraie batterie type 18650 (sans marque) 3000mAh et plus aucun problème : swings et FoC parfaits, sons impeccables. RAS !
Mon test a duré qqs minutes mais ni-kel !
En revanche, par rapport à tes réglages, je suis surpris : si je change les valeurs de lsfadeon/off à 1, toutes les LED s'allument en même temps. Progressivement, mais en même temps. Pour avoir l'effet progressif de l'allumage une LED après l'autre, je dois laisser les valeurs à 0...
Je n'ai changé aucun autre paramètre (focmix, tout ça...)

Mais pour le grésillement et autre, à mon avis, c'est ta source d'électricité...
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Mar 19 Déc - 19:02

Merci Beloube pour ta réponse, j’ai fait un test avec une autre 18650 (achetée chez JQ), c’est pareil ! À défaut, si t’as un lien pour une batterie ok, je prends bien volontiers !

Concernant l’allumage de toutes les diodes en même temps, de mémoire c’est lightstick qu’il faut mettre à 1. Fadeon et fadeoff donnent l’effet de sortie et de rétractation (si j’ai bien compris la doc !).

Merci pour ton aide !

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Mar 19 Déc - 19:22

avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Mar 19 Déc - 22:33

Super ! Et côté cymbales, t’es plutôt Zildjian !?!?

Merci pour les liens, demain je refais un test avec l’artillerie : deux bandeaux, ampèremètre, voltmètre, café et alim de labo !

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Mer 20 Déc - 12:02

Djecko a écrit:Et côté cymbales, t’es plutôt Zildjian !?!?!

Exactement Wink

Bon courage pour les tests ! de mon côté, avec toutes ces manipulations, mes fils se sont dessoudés... Mad j'ai aussi du taf !
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Mer 20 Déc - 20:34

Deuxième test aujourd'hui avec une modification du programme.

Intrigué par tes précisions Beloube, j'ai remis le lsfadeon et lsfadeoff à 0.

Recâblage de la même façon, avec la même batterie et là, contre toute attente : ça marche nickel. Bleu, vert puis rouge, son nickel et clash nickel. C'est comme si cette option tirait trop de courant à la batterie. J'ai pas tout compris, mais ça marche.

A nouveau mesure du courant délivré par l'alimentation, on est sur du 1A pour vert et bleu et 1,2A pour le rouge pour un seul bandeau de 144 led.

Lors des tests, il m'est arrivé un truc étrange pour ne pas dire inquiétant.

Incriminant jusqu'alors la batterie (son qui grésille = batterie trop faible, c'est même marqué dans la doc), je teste avec une alimentation de labo dont le courant est limité à 3A. Je règle la tension à 3,7V, et là : encore le problème, c'est même pire. J'ai pu constater que si la tension d'alim est supérieure à 4V, tout fonctionnait bien.

Ceci m'inquiète car la batterie va rapidement se décharger et j'ai peur que le sabre se mette à faire n'importe quoi car la tension chute trop. A suivre.

P.S. : merci Beloube et bon courage pour tes travaux de soudure ;-)

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Jeu 21 Déc - 9:07

Tiens... c'est bizarre, en effet ! Mais tant mieux si ça fonctionne, hein ?
A mon avis, ta pile tiendra le choc ! Quand j'utilisais 3 piles Varta R03, même neuves, rien ne fonctionnait plus de 1 min. Après, grésillements, coupures, re-boot, toussa, toussa...
En câblant "en l'air" ma 18650 chinoise, tout à disparu instantanément.
Elle tiendra le choc !

Après, j'hésite à utiliser ça :


Je sais pas trop...

Question(s), tout de même : as-tu modifié des paramètre du fichier "override" ? typiquement ls0 et ls1 ?
J'ai testé diverses valeurs et ça bogue grave pour toutes valeurs de ls0 < 10. Mais du moment que ça fonctionne (ls0 = 10 ou 11 ou 12...) je ne vois guère de différence...
En fait, j'aimerais que la durée de l'allumage de la lame soit plus cohérente avec le son du poweron : grossièrement, ma lame s'allume en 1,5sec mais le son poweron ne dure que 0,75 sec... Il y a donc un petit temps ou on entend déjà le "hum" mais la lame n,'a pas fini de s'allumer en plein. J'arrive pas à gérer ça, j'ai pas trouvé le réglage. Il y en a un ? Tu sais ?

Smile
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Jeu 21 Déc - 11:59

J'ai acheté les connecteurs dont tu parles, quand je passerai à l'assemblage, je te dirai ce que ça donne ! Pour l'instant, toujours en attente du sabre, j'en profite pour me roder sur les réglages de carte.

Pour les valeurs ls0 et ls1, Erv indique dans la doc de la Nano (page 33) que ls1 = 2ls0. La valeur de ls0 doit être lue dans la documentation de ton bandeau de led. J'ai regardé sur les WS812 que propose Adafruit, je pense que le ls0 doit correspondre au "transmission delay time", donné à 300ns dans mon cas, ça ferait un ls0 = 300/25 = 12, d'où un ls1 = 24.

Pour l'instant, j'ai laissé les valeurs par défaut, à savoir ls0 = 14 et ls1 = 28 et force est de constater que ça fonctionne bien. A titre de curiosité, je tenterai une modif pour voir concrètement l'impact que ça a.

Concernant le problème d'allumage, j'ai sensiblement le même souci. Le sabre passe en hum alors que toutes les diodes ne sont pas encore allumées. Je n'ai pas pu encore tester mais je crois que la solution est le paramètre qon : pages 19 et 34 (dernier paragraphe) de la doc.

Par défaut à 0, ce paramètre peut être réglé jusqu'à 3000 (ms, j'imagine ?). Faudrait voir quel temps dure ton allumage (hors hum) et entrer la valeur dans ce paramètre. Sur ma carte, à l'aide d'Audacity, j'ai trouvé 0,9s pour l'allumage, je ferai un test avec qon = 900, on verra bien !


Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Jeu 21 Déc - 12:33

Bien vu Wink
J'essaierai aussi du coup !
Et je veux bien ton retour sur les connecteurs Wink
On va y arriver !

Very Happy
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Kruhl Ilios le Jeu 21 Déc - 12:52

Moi j'ai fini ma lame, ah que c'est bon Smile
avatar
Kruhl Ilios

Messages : 274
Date d'inscription : 27/10/2014
Age : 36
Localisation : Val de Marne 94 Limeil Brevannes

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Beloube le Jeu 21 Déc - 21:11

Djecko a écrit:
Par défaut à 0, [qon] peut être réglé jusqu'à 3000 (ms, j'imagine ?). Faudrait voir quel temps dure ton allumage (hors hum) et entrer la valeur dans ce paramètre. Sur ma carte, à l'aide d'Audacity, j'ai trouvé 0,9s pour l'allumage, je ferai un test avec qon = 900, on verra bien !

Ca marche pô du tout... La doc dit :
Qon [0-3000]: "allumage - rapide". Permet l'allumage de la lame sur un temps spécifique donné. Ce temps ne doit pas excéder la durée du son poweron.

Et visiblement la valeur 900 est trop élevée. Mon allumage est progressif sur les 9/10è de la lame puis le dernier 10è s'allume d'un seul coup et le "hum" se coupe (mon sabre devient silencieux) jusqu'à la première perturbation (swing ou FoC) et là, le son repart normalement.
J'essaie avec 300... J'éditerai au besoin.

Edit : CA MARCHE !!!! C'est génial ! A affiner "à l'oeil"... avec 300 je trouve cela un poil rapide. Je passe à 350.

Trop bien Twisted Evil

Edit #2 : @Kruhl Ilios : chuis trop d'accord ! I love you
avatar
Beloube

Messages : 24
Date d'inscription : 09/12/2017
Age : 41
Localisation : Avant-Pays Savoyard

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Djecko le Ven 22 Déc - 7:53

Bon, le qon n'est pas exprimé en ms alors !

Un grand merci pour ton partage Beloube, je teste ça à mon tour dès que possible !

@Kruhl Ilios : n'hésite pas à partager les réglages que tu aurais fait sur ta carte ou bien ton choix de matériel !

Djecko

Messages : 153
Date d'inscription : 01/06/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Lame Neopixel

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 4 1, 2, 3, 4  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum